Adobe flash player / shockwave player

Cloud created by:

Joe Clark
7 July 2017

I was trying to play ben 10 games on cartoon network when it told me that it needs both "Adobe flash player / shockwave player" I tryed to download both but didn't work I have a windows 10 64-it computer using google chrome so can anyone help
 

Extra content

Embedded Content

Contribute

Contribute to the discussion

Please log in to post a comment. Register here if you haven't signed up yet.